Commit dbba854b authored by Nicolas Richard Walter Boeckh's avatar Nicolas Richard Walter Boeckh 💬

+ BT Unabailable + Localization

parent d8dcdda6
......@@ -36,5 +36,10 @@
"@bluetoothAvailable": {
"type": "text",
"placeholders": {}
},
"bluetoothUnsupported": "This device does not support Bluetooth Low Energy",
"@bluetoothUnsupported": {
"type": "text",
"placeholders": {}
}
}
\ No newline at end of file
......@@ -36,5 +36,10 @@
"@bluetoothAvailable": {
"type": "text",
"placeholders": {}
},
"bluetoothUnsupported": "Cette appareil n'est pas compatible avec Bluetooth Low Energy",
"@bluetoothUnsupported": {
"type": "text",
"placeholders": {}
}
}
\ No newline at end of file
{
"@@last_modified": "2020-02-13T17:57:48.355903",
"@@last_modified": "2020-02-14T18:33:12.826799",
"ok": "OK",
"@ok": {
"type": "text",
......@@ -36,5 +36,10 @@
"@bluetoothAvailable": {
"type": "text",
"placeholders": {}
},
"bluetoothUnsupported": "This device does not support Bluetooth Low Energy",
"@bluetoothUnsupported": {
"type": "text",
"placeholders": {}
}
}
\ No newline at end of file
......@@ -24,6 +24,7 @@ class MessageLookup extends MessageLookupByLibrary {
"bluetoothAvailable" : MessageLookupByLibrary.simpleMessage("Available Devices"),
"bluetoothFrequent" : MessageLookupByLibrary.simpleMessage("Frequently Used Devices"),
"bluetoothScanMessage" : MessageLookupByLibrary.simpleMessage("Scan for Bluetooth Devices"),
"bluetoothUnsupported" : MessageLookupByLibrary.simpleMessage("This device does not support Bluetooth Low Energy"),
"cancel" : MessageLookupByLibrary.simpleMessage("Cancel"),
"locationPromptReason" : MessageLookupByLibrary.simpleMessage("To use Bluetooth Low Energy and to increase data collection accuracy, this permission is required."),
"locationPromptTitle" : MessageLookupByLibrary.simpleMessage("This app needs to use location services"),
......
......@@ -24,6 +24,7 @@ class MessageLookup extends MessageLookupByLibrary {
"bluetoothAvailable" : MessageLookupByLibrary.simpleMessage("Appareils Disponibles"),
"bluetoothFrequent" : MessageLookupByLibrary.simpleMessage("Appareils Fréquemment Utilisés"),
"bluetoothScanMessage" : MessageLookupByLibrary.simpleMessage("Recherche d\'appareils Bluetooth"),
"bluetoothUnsupported" : MessageLookupByLibrary.simpleMessage("Cette appareil n\'est pas compatible avec Bluetooth Low Energy"),
"cancel" : MessageLookupByLibrary.simpleMessage("Annuler"),
"locationPromptReason" : MessageLookupByLibrary.simpleMessage("Afin d\'augmenter la précision de la localisation et pour utiliser Bluetooth Low Energy, cette permission est nécessaire."),
"ok" : MessageLookupByLibrary.simpleMessage("OK")
......
......@@ -61,4 +61,9 @@ class InternalLocalization {
'Available Devices',
name: 'bluetoothAvailable'
);
String get bluetoothUnsupported => Intl.message(
'This device does not support Bluetooth Low Energy',
name: 'bluetoothUnsupported'
);
}
import 'package:flutter/cupertino.dart';
import 'package:flutter/material.dart';
import 'package:logair_application/localization/localization.dart';
showBluetoothUnavailableDialog(BuildContext context) async {
showDialog(
context: context,
builder: (BuildContext context) {
return SimpleDialog(
children: <Widget>[
Text(InternalLocalization.of(context).bluetoothUnsupported),
SimpleDialogOption(
child: Text(InternalLocalization.of(context).ok),
)
],
);
}
);
}
\ No newline at end of file
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment